Headshot-Sparks acting weird when recording (GoldSRC)

Post Reply
bastian
Posts: 10
Joined: 2017-05-30T19:20Z

Headshot-Sparks acting weird when recording (GoldSRC)

Post by bastian » 2017-11-11T22:14Z

Hi friends,

today I encountered a new issue. It only occurs with one HLTV-demo but I don't figure it out. So here's my problem:

I'm talking about the sparks that are coming from the helmet when getting a headshot.
I quickly googled a picture, just to clarify what I am talking about:

Image

The thing is now, when I play the demo - everything acts normal. But as soon as I start recording (even with mirv_movie_simulate 1 it's the same), those sparks fly 10 meters in like 5 frames. Really fast and not normal.

I restarted everything and checked my settings, but every other demo works just fine. I also tried sv_gravity settings but no change.

Any suggestions?

Thanks,
Bastian

dtugend
Posts: 1080
Joined: 2007-07-26T10:20Z
Location: Germany
Contact:

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by dtugend » 2017-11-12T13:10Z

the sparks probably depend on your FPS, don't forget to set the recording FPS properly:
https://github.com/ripieces/advancedfx/ ... _movie_fps

bastian
Posts: 10
Joined: 2017-05-30T19:20Z

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by bastian » 2017-11-12T13:24Z

Thank you for the reply, but I already tried various settings - no change.
I also tried different demo speeds.
No matter what, as soon as I hit mirv_recordmovie_start, the sparks fly with lightspeed AND for example when a player gets hit on the de_nuke catwalk, usually the sparks drop to about his feet. But now they are not only fast but also fly down through the ground to the lower floor.

I will probably capture this demo without HLAE. But I have seen this behaviour a few times in other movies I think, so I keep wondering what the matter is here.

dtugend
Posts: 1080
Joined: 2007-07-26T10:20Z
Location: Germany
Contact:

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by dtugend » 2017-11-13T05:54Z

Which HLAE version are you using?

HLAE 2.34.5 (2017-07-08T14:48Z)
or HLAE 2.2.21.14 (2013-02-09T14:16Z)
?

bastian
Posts: 10
Joined: 2017-05-30T19:20Z

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by bastian » 2017-11-13T12:49Z

I'm using 2.34.5

bastian
Posts: 10
Joined: 2017-05-30T19:20Z

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by bastian » 2018-05-12T00:10Z

Ok, I have an update on this matter!
The bug occurs if:

- mirv_movie_separate_hud is set to 1 or 2
- mirv_movie_splitstreams is set to 2 or 3

If any of these settings are used, the bug occurs and any sparks (from helmet-headshot or shots in the wall) behave unusual (they fly down insanely fast and also way too far, like from nuke catwalk to lower ground).

Maybe this is a hint for any solution?
Right now I am capturing different streams one after another, but this is very inconvenient and in some cases I cannot do what I want to do with matte effects, also I have no workaround for clips with AWP-zoom, because I dont know how to get rid of the zoom-hud without separate_hud command.

dtugend
Posts: 1080
Joined: 2007-07-26T10:20Z
Location: Germany
Contact:

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by dtugend » 2018-05-12T10:13Z

Hi.

I was asking earlier, because I thought the problem had been addressed between
HLAE 2.34.5 (2017-07-08T14:48Z)
and HLAE 2.2.21.14 (2013-02-09T14:16Z).

Please understand we are not supporting AfxHookGoldSrc anymore at the moment, you can read more about that here:
GoldSrc (HL1 / CS 1.6 / ...) support is officially dropped
viewtopic.php?f=17&t=2127

bastian
Posts: 10
Joined: 2017-05-30T19:20Z

Re: Headshot-Sparks acting weird when recording (GoldSRC)

Post by bastian » 2018-05-12T11:47Z

Yes, I know there is no support anymore and I dont want to bother you.
I'm still using 2.34.5.
Maybe you happen to know a trick how I can remove the black HUD when zooming with the awp? If I could get this out of the worldstream without separate_hud I would be happy. I tried the usual things like replacing sprites and editing some files but so far no luck.

Post Reply